I love pixels! They’re the building blocks of all the visual design we do here at ustwo™, but are so often relegated to a mere afterthought in the excitement of working with colours and styles. The aim of this Pixel Perfect Precision™ handbook is to bring them back to the forefront of our thoughts, to make sure we get the simple things right before moving onto the detail.

Why is this important though? Isn’t it just wasting time worrying about every last pixel on the page? Like a lot of things in life, when something’s done right it should become invisible to you, but when it’s done badly it becomes an annoyance. Blurred edges, objects that jump in position between pages, and colour mismatches are just a few things that a user will notice and become distracted by if your designs aren’t done properly, leaving them with a poor impression of the product.

For this latest release we’ve separated the Photoshop-specific advice from the core principles (and expanded on them) to make the handbook more useful across a range of disciplines; we know that there are lots of interaction designers and developers out there who want to learn about this area of design, so we’ve made the handbook a more relevant resource for you. There’s also a completely revised section on Accessibility, an area we feel needed the PPP™ treatment to give you the essentials you need to know in an easy-to-understand way.

Gyppy xx
Acknowledgements

There’s a few people out there who I’d like to thank: first of all Shiro, for showing me the true meaning of pixel precision all those years ago; all the designers out there who share their knowledge, such as Teehan +Lax, Marc Edwards, Daniel Cooper, and Tobias Ahlin to name but a few; and most of all I’d like to thank ustwo™ for letting me indulge my passions and create this handbook!
The Essentials

This first section covers a lot of core principles and topics that apply to all digital design and its relevant tools. For seasoned designers it can act as a refresher for things to look out for and consider, and for those starting out it offers a quick start guide to some of the processes and thinking that we apply to projects.
Pixel Perfect Principles
Sharp Edges

Straight edges should be on-pixel and sharp – blurred edges are a no-no!
Once you’ve mastered the art of getting everything sharp the next step in your journey towards pixel perfection is to get the alignment and spacing right.

Alignment & Spacing

X Naughty

✓ Nice
Consistency

Alignment of objects across multiple screens is just as important. Margins and placement of common items such as title bars, back buttons, and footers should be the same throughout the interface to prevent objects jumping around.

The best way of doing this is to set yourself up a grid, which will define a structure that can be followed throughout your screens.
Environment refers not only to the platform you’re designing for, but also how it will be operated and the physical space that it will be used in. For example, TVs have a completely different set of variables to mobile phones – they are viewed from a much greater distance, are almost always used indoors, and are operated via remote. This in turn means different considerations for things like text size, colours, and contrast within the interface.
Accessibility

Accessibility is a broad topic, being relevant to every one of your users – not just those with some kind of disability. Good practice such as ease of use and clarity are a given and go a long way in this area, but there are also steps you can take to make your work more accessible for those with conditions such as colour blindness and dyslexia. See the Accessibility chapter for more information.
Affordance

Affordance is an object’s ability to convey its function through sensory means, for example by being slightly raised a button suggests that you press it; by being the right size and position for a hand a door handle suggests that you pull it.

This technique can also be used in digital design to hint at how objects should be interacted with: commonly used affordances include buttons which are given depth like in the real world, and text which flows off the page so it looks like it scrolls.
Some colours and shapes have become synonymous with certain functions and messages within interface design. Be mindful of these, as mixing them up can cause confusion for the user if they’re expecting the opposite. Green and ticks are commonly used to infer good, likewise red and crosses bad, but by jumbling the two up you create a mixed message. Similarly, yellow and triangles are often associated with warnings, blue and circles with information.
Visual Hierarchy

Layout, colours and typography have a huge influence on how information is seen, and what the eye is drawn to. Think about what you want the user to look at on the page, and in what order, then start designing around that hierarchy. Grab attention with high contrast and large, bold type, or push items back with lower contrast and smaller, lighter type weights. Culture also plays a part: for example Westerners will naturally start near the top of a screen as that’s the way we read.
Typography is an often overlooked part of the digital experience, but since most information is conveyed through text it’s one of the most important parts of a design. The same basic principles as for any other medium apply – is it a comfortable size for reading without squinting? Is there enough leading and are the line lengths short enough to make reading comfortable? Don’t just accept the default font settings in your design environment – treat type with the respect it deserves!
Testing

This step has a close link to Environment in that you may know a lot about the platform you’re designing for, but nothing beats testing on actual device(s). Screen resolution and technology can vary dramatically compared to your computer, not to mention switching from mouse and keyboard to other types of input. There are a wide range of live previewing tools available these days that will take a design from your computer and place it directly on your device, updating in real time as you apply changes. Make sure to use them!
Organisation

No man is an island, and most of the time your files won’t be either! Good organisation is essential when sharing designs as it saves a lot of time for other people. Well ordered files and layers mean other designers can jump straight into your work and find their way around, and a logically named set of assets will make a developer very happy.
Take a Break

It’s very easy to get completely consumed in the design process, but sometimes it pays to take a break – not just for health reasons, but also the different perspective a refreshed set of eyes can bring. Go and make yourself a brew, or wander somewhere else for a few minutes: after coming back the solution to a design problem might be staring you right in the face, or you might spot a flaw that had previously gone unnoticed!
Pixel Perfect
Details
HSB FTW! Have a go at using HSB as a colour model when creating a palette: once you get your head around it you'll see it's a really efficient way to create shades of a base colour. In the example the Hue (H) value has been kept the same, then the Saturation (S) and Brightness (B) changed to create the variations. See how much more sense the numbers make in HSB compared to RGB?
Colour Management makes a lot of sense in a print environment, but for digital it can often create more problems than it solves. The main issue is that it’s not available throughout the development process – you can manage your assets, but when they’re mixed with unmanaged code (specifying the same original colour) there can be a mismatch. Much better to ignore colour management altogether, and instead test on the device – unlike print this takes a matter of seconds and costs nothing!
A great way to check the maximum height that a block of text can be is to use the Åy characters. If a design needs to fit a minimum number of characters then use a series of capital Ws to judge the space needed – if they fit then anything else will too.
If you’re working on a design that will be used with other languages it’s also worth considering how long your text could be when translated. The example above shows what happens with the German and Portuguese translations of Settings: an increase of up to 75% in length.
Aligning Text on Buttons

Featured above are three ways to vertically aligning text on buttons. There are a few variables which can affect which method is the best, such as the typeface used (for example the cap height to x-height ratio can vary) or whether you’re using upper- and lowercase text or caps/numbers. The most important thing though is to make sure that once you pick a rule you use it on every button – consistency is king!
Aligning Text with Objects

Try to vertically align text using the x-height, ignoring ascenders and descenders. This means that dynamic text, which could contain any combination of characters, will always look correctly aligned.
Borders & Corner Radii

You’ll often want to create some kind of border for your components, in which case how do you work out the outer radius when you’ve already set the inner (or vice-versa)? There are a few methods, the most common being shown above: matching the inner and outer radii, scaling the original shape in size, and adding the border and original inner radius together. The latter is by far the best method, resulting in consistent outlines that don’t thicken at the corners like the other two.
If you use the preferred method, but start from the outer radius and work your way in by subtracting the border width, you may end up with inner corners that are completely square. In those situations it may be worth adding a small radius to those corners: even though it is mathematically “incorrect” it may look better from a visual perspective. In the engineering world this process is known as filleting, with each individual corner called a fillet. For an in-depth article on borders and corner radii check out this article from Radesign.
Equilateral Triangles

A lot of graphics applications won’t give you an equilateral triangle when you draw a three-sided polygon, instead they’ll make the width and height the same. To quickly convert to an equilateral scale the height (with one face horizontal) by 86.6%.

Naughty

Nice
Although there are now a multitude of version control systems available for designers to use more often than not we still end up saving files manually. To make it easier to keep track of files and revisions we use a system like that shown above. The most recent file, `Screen.psd`, is kept at the top level of the working folder. At the start of the day, and at other key points, that file will be duplicated, placed in the Archive folder, and given a filename based on the date (YYMMDD so it shows in the right order) and revision number. Tidy!
Naming Systems

Coming up with a standard naming system for your assets and components on a project eases the transition from design to development and will make everyone happy! Although different people and studios will have their own individual way of doing things a good approach is to base your naming on a hierarchical system, which starts off with a broad identification of the component and then progressively adds more levels of detail. So you might use a structure like this:

```
type_location_identifier_state
```

The `type` refers to what category the component belongs to, such as:

- `bg` (background)
- `btn` (button)
- `icn` (icon)

The next step is to add the screen or location where this component appears:

```
bg_help  btn_home  icn_global
```

(global refers to components that appear across multiple screens or sections)

Then add the unique identifier, so buttons on the home screen which create and delete documents would be called:

```
btn_home_new  btn_home_delete
```

The final part is to add the state if it’s interactive or changes at any point:

```
btn_home_new_default  btn_home_new_highlighted
```

As an aside the system shown here uses lowercase letters and underscores instead of spaces in the names, which is our usual choice, but another method is CamelCase, which uses no spaces and instead capital letters to define each part of the structure:

```
BtnHomeNewDefault  BtnHomeNewSelected
```

The final, and most important, point to make is that the best way to go about all this is to speak to the developer you’re working with and see which system they like to use, and then adapt what you’re doing to that!
Naming Systems

Example
Accessibility
Accessibility

Accessibility isn’t about creating compromised products for those with disabilities, but instead means good, inclusive design made for everyone. You don’t need to make huge sacrifices in terms of visual appeal, or spend lots of extra time and money making your designs comply to standards: like pixel perfect precision, if you make these principles part of your design-thinking and build them in from the start then you’ll find accessibility takes very little time at all.

“If I make my design accessible won’t it look rubbish?”
Around 10% of the UK population have some form of disability, which is a large number of potential users to consider. There are four main types of impairment that will commonly affect digital projects – sight, hearing, touch and cognitive i.e. the ability to process those other three senses. You shouldn’t rely on just one of them to make your product or feature usable, but instead allow multiple forms of interaction and communication where possible – for example enabling text-to-speech functions for visually impaired users.
Keep your designs as clear and concise as they can be to avoid overloading the user with too much content. You can do this by showing information which is relevant to the context of the user, and then use progressive disclosure to reveal more details as they require. It is also important to consider adapting your content so that it’s suitable for mobile devices – for example keeping image sizes small for those on data connections.
Break up large blocks of text so they’re easier to digest and keep track of. Use somewhere around 5 lines as a maximum and you’ll not go far wrong!
Some users, such as dyslexics, can have poor organisational skills so consider breaking down long paragraphs of text into lists or diagrams, which help them by presenting the information in smaller, ordered chunks.
If you’re using abbreviations make sure to include their expansion when they first appear. Better still try to avoid them altogether, as remembering what they stand for can prove difficult for some users.
Consistency

Your designs should maintain consistency across a number of levels – for example their styling, navigation, typography, and use of language. Interface elements should behave in a standard way throughout the app, and also where possible follow any conventions or patterns from the host operating system – this will mean that the user can predict how the product will behave based on their experiences with other apps. Most major devices have guidelines for their design and interaction patterns.
Navigation

Following on from the previous point about consistency, navigation should follow the same principle as it will help the user get around your app without feeling lost. Elements that help the user move through the app should be positioned in the same place across all screens, using the same styles and labels. This also applies to other parts of the interface, for example if a button initiates a certain action in one part of the app then it should also perform the same action if activated elsewhere.
When creating the layout for a page really think about why the user is there and what they want to find out. Based on that, structure your content in a way that the most important parts are the easiest to reach.
Although care must be taken not to cram too much on to one screen, also be mindful that by introducing too many steps you also create hassle for your users. Try to make all information accessible within four pages: any more can cause frustration.

**Navigation**

**Minimise Steps**
Clearly title pages so that the user knows where they are, and the context of the information presented to them.
Keep your content to an appropriate page size and try to introduce breaks where it makes sense. Scrolling through a page is much easier than linking between them and also reduces the amount of page requests, which will be beneficial to mobile users. Don’t make the pages too long though as no one likes to endlessly flick down!
Make sure your content only needs to be scrolled in one direction – it’s much easier for the user both physically and mentally, as they won’t need to pan around trying to keep track of what they have and haven’t seen.
If you’ve got more than three or four points in a list consider using numbers instead of bullets – these provide some structure which aids navigation through the content.

**Navigation**

**Numbered Lists**

- Pink
- Orange
- Green
- Blue

1. Pink
2. Orange
3. Green
4. Blue

**Naughty**

**Nice**
Labelling objects in an interface for use with text to speech functions is an art form in itself! Labels need to be clear so that users know what’s going on, but also concise so that they don’t take too long to listen to.

“This is a button that initiates Action. By pressing it you will proceed to the next screen of the app.”

“Go to next screen”

**Naughty**

**Nice**
Interaction

Touch Targets

When designing for touch-based devices it’s important to consider how easy it is to operate using fingers and thumbs. We usually base our designs on a minimum touch area of 7mm², which is the rough size of the contact area between a finger and screen, and then leave at least a 2mm gap between items so they don’t get accidentally pressed. If you’ve got components that are intended to be primarily thumb operated then it’s a good idea to make those wider, as the average width of an adult thumb is 25mm.
When requesting user input provide default values rather than just free text entry as it will reduce the chance of input errors.
Buttons are the commonly used method of initiating actions in applications, so if you opt for hyperlinks instead you'll confuse the user.
And talking of hyperlinks don’t underline text that isn’t a link as again this will cause confusion – users may think something is wrong when they tap and nothing happens.
Feedback

You should always let the user know what’s going on when they’re in your app. If they perform an action that needs some processing or uploading time then show a spinner rather than simply freeze the screen so they know it hasn’t crashed. Similarly, if an error occurs notify them rather than revert back to a previous screen.
Feedback
Multi-sensory

Provide feedback in multiple forms where possible. For example, relying solely on sound for an alert would mean that deaf users, or those located in noisy environments, wouldn’t be aware that something has happened which requires their attention.
If something goes wrong then let the user know what’s happened in an understandable way, and then provide them with the option to navigate back to somewhere useful.

Error code 04 type 11
An error has occurred in the bus_1234 Library. This problem has caused a crash in the dynamic states of the system. Please contact your sys admin on the IT floor.

Something went wrong!
But don’t worry, press Return to go back to the previous screen.

Naughty

Nice
When designing forms place the error messages next to the relevant field rather than separately – this will help the user identify the error much more easily.

- Naughty

- Nice

**Typography**

As mentioned in Pixel Perfect Principles good typography is vital in digital design, and has a great effect on your product’s accessibility. The basics of good line length and leading are always important, especially when considering users with visual or cognitive impairments – by keeping text light and legible you’ll help these users navigate easily from one line to the next.

Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Pellentesque a nibh nibh, vel dictum risus. Nunc congue vestibulum nibh non sollicitudin. Donec eget metus leo.


Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Pellentesque a nibh nibh, vel dictum risus. Nunc congue vestibulum nibh non sollicitudin. Donec eget metus leo.


Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Pellentesque a nibh nibh, vel dictum risus. Nunc congue vestibulum nibh non sollicitudin. Donec eget metus leo.

X Naughtly

✓ Nice

Typography
Alignment

Multiple lines of text should always be left-aligned, as the inconsistent spaces in justified and centred text can be a problem for users with learning difficulties. Justification can also create distracting white rivers running through the paragraphs.
Keep text formatting as simple as possible so it’s legible for your users. Serif type is harder to read for visually impaired or dyslexic users as it’s styling can obscure the shape of the letters; similarly italics and underlines add visual noise. Capitalisation of whole sentences or paragraphs also makes text more difficult to read AND LOOKS LIKE YOU’RE SHOUTING!
Lastly, avoid moving or blinking text as visually impaired and dyslexics users can find this very distracting, and also there are epilepsy issues to consider with blinking/flashings.
Truncate text only where necessary, as it hides useful content.

Example 1

Example 2

Example 3

× Naughty

✓ Nice
Wherever possible try to keep text separate from graphics, and instead implement it at a code level. This will allow any text-to-speech functions on the user’s device to pick it up and read it out loud, and also lets the user increase the size of the text or adjust the colour to their preference, which won’t be possible with a fixed graphic.
Using icons and colours as visual aids can help users identify important content on the page, or can be used to colour code types of content or areas in your app, which can be especially useful to those with cognitive impairments. Make sure that it is used consistently though!
However, don’t rely on colour alone to communicate information. Mobile devices can have poor colour contrast and are sometimes used in less than ideal lighting situations, which may mean that colours aren’t visible to users. It is also worth noting that around 8% of males have some form of colour blindness, again having an impact on how well colours will work.

**Colour**

**Don’t Rely on Colour Alone**

- Passed
- Failed

- Naughty
- Nice
If you’re using colour to present information, such as the bars in a graph, then try to introduce a secondary method of distinguishing between them; in this case patterns have been introduced to the orange and blue areas.
Always make sure that text and other important information has enough contrast between foreground and background colours, so it’s still legible for those with some form of colour blindness or other visual impairment.
There are numerous tools out there which can be used to test your colour contrast. One of the most useful is Colour Contrast Analyser which can be found here. There’s also a great online checker available here – just pop in the two colours and away you go! As a minimum you should aim to pass AA standards; AAA is better but needs a lot of contrast, too much of which could have a negative impact on your designs. The tests also differentiate between body sized copy and “Large” text which is 18pt and above (or bold and larger than 14pt).
What would you do if you wanted to describe colours, but didn’t want to use text labels? Turns out a great solution already exists: **Color Add** is a simple system that represents colours using symbols. By combining these symbols, representing the three primary colours in subtractive light, you can mix and match together to create the whole spectrum – just as you would with paint or ink. It’s also possible to represent light and dark shades by merging these symbols with those for white and black.
There’s lots more information on their site, including some great colouring pencils for colour blind people!
Testing

Another piece of good practice that applies to accessibility as well! Once you’ve created your product, test out how well it works with various accessibility features such as black & white, zoomed view, and text-to-speech. These features can often be tested in app simulators, but of course the real thing is even better. Speaking of real things, the best way (as always) is to test with people that use these features!
Tucked away in the View > Proof Setup menu are a couple of options to preview how your design will look to people with the common forms of colour blindness – this is a great way to quickly see if there are any issues with colours and contrast.
Sim Daltonism is a more advanced application for checking colour blindness accessibility, and can test many variations of the condition. Rather than being a Photoshop only tool it works across the entire OS, providing a resizable floating window that previews whatever is underneath the mouse cursor.

Testing Sim Daltonism
So now that we’ve covered a lot of design principles let’s dive right into some specifics. Although there’s been a lot of noise made about alternatives to Photoshop, including budget apps and designing in code, it’s still our day-to-day tool here at ustwo™ (and across the industry as a whole), so knowing how to use it well is vital. The following sections show you some of the processes and techniques that we use here.
Photoshop: Colour Profiles
To avoid any nasty colour jumps between Photoshop and Mac OS X the colour settings need to be set up correctly. First thing to do is make sure System Preferences > Displays > Color is set to the device you are currently using (for laptops this is Color LCD).
Photoshop Colour Settings

Next, in Photoshop, go to Edit > Color Settings... and change Working Spaces > RGB to the screen specified in your System Preferences. Also change Color Management Policies > RGB to Off.
Photoshop Save for Web

Additionally, in Save for Web the Convert to sRGB option needs to be deselected, and Preview should be set to Monitor Color. Your colours should now be consistent!
Although following the previous steps should set you up for most day to day tasks, there’s one last piece of advice to give concerning profiles: if you’re having trouble with colour values in Apple software such as Xcode or Keynote then it will probably be down to the way that OS X handles profiles. For an in-depth explanation read this article; the long and short of it is that you should download Color Faker and switch it on!
Photoshop: Pixel Precision
Shape Layers

We love Shape Layers here – our workflow is almost entirely based on them. Being vectors they’re completely editable, allowing scaling and transformation of the shape with no loss in quality, and are less resource hungry than Smart Objects or bitmaps. Winner.
Also, try to use vectors for other parts of your design where you might automatically use a bitmap, for example layer masks, as this will further increase the versatility and speed of the file. Another related tip is to use unmasked Shape Layers for backgrounds, which have the added advantage that the fill will automatically scale if the canvas size is increased. Nice.
As an illustration of the performance hit that bitmaps create take a look at the two values highlighted above. These are document size readouts for the layers featured on the previous page: the vector design only uses 260Kb of memory, but the all-bitmap version takes up around five times the amount at 1.27Mb! By using vectors for everything possible on a large file you can save yourself hundreds of megs of memory.
Another thing we love here are Layer Effects, so we try to create as much styling as possible using them. The effects are completely editable, can be scaled in ratio to their underlying shapes, and can be quickly copied and pasted to other objects.
As well as using the measurement readout when drawing vector shapes or using the marquee tool to get some super pixel precision, there is also the Info Panel for extra detail. Not only does it show measurements but it can also display colour and opacity values that will allow you to quickly check consistency throughout a design.
Snap to Pixel Grid

With Photoshop CS6 there is a global option to snap vectors to pixels in the Preferences – make sure Snap Vector Tools and Transforms to Pixel Grid is selected (it's on by default). Much easier knowing that every Shape Layer you draw will automatically be pixel precise!
Snap to Pixel Grid Actions

There may be times when you’d like to alter Shape Layers on a sub-pixel level, in which case you won’t want them to snap to the pixel grid. If you find you want to toggle the snapping on and off like this quite often then why not automate it? Simply set create a new Action, assign a Function Key shortcut to it, and then record yourself going in to the preferences and switching the Snap Vector Tools and Transforms to Pixel Grid option on; then record another Action for off. No need to hit the preferences any more!
Shape Layer Options

In Photoshop CS5 Rectangles and Rounded Rectangles have a built in option to aid pixel precision: *Snap to Pixels*. To access this option click the drop-down menu to the right of the shapes in the top tool bar. This needs to be selected for both Rectangle and Rounded Rectangle individually as their options are independent of each other.
Nudging

If you’ve got Photoshop CS5 be careful when using the keyboard to shift points of a Shape Layer when zoomed into a design – the nudge amount varies according to the zoom factor. To guarantee a 1px nudge, zoom out to 100% and press the arrow key once. If zoomed in at 200% though the points will only move 0.5px (i.e. half the amount), creating blurred edges – not good. With CS6 pixel grid snapping the points will move 1px no matter what level the zoom is; you’ll need to switch off the snap to move by smaller increments though.
Snapping

Photoshop has lots of handy tools to help with pixel precision. One of the first things to do when setting up the program is to enable snapping – go to View > Snap and make sure it’s on. Now your objects will snap to other items and guides on the canvas, which really helps with alignment. The Snap To submenu shows the various items that Photoshop can use for snapping.
Alignment & Spacing

As with most graphics applications Photoshop has align and distribute tools – find them in the Layer > Align and Layer > Distribute menus.
Sometimes it’s useful to have a grid on screen when creating a layout. The example above is using 10px gridlines with 10 subdivisions, which makes it easy to count pixel dimensions and stops the grid from becoming visually overpowering when used.

Go to Photoshop > Preferences > Guides, Grid, & Slices... to set yours up.
To help automate the creation of guides there’s a free Photoshop Extension available called GuideGuide; once installed it can be found in the Window > Extensions menu. By varying the data you enter it can work out measurements such as column and gutter widths, or if you’ve already sussed these out on a scrap of paper you can just input all the values and get your guides inserted automatically. There are tooltips for each of the input box icons to let you know what each one does.
Global Light Default Angle

This is one of those little things that Photoshop will catch you out on if you’re not careful. If you’ve set up a design with a custom Global Light direction, then drag an element from it to a new document, it will take on the default 120° instead. As you can see in the images above this can mess up the design. To help prevent this from happening too often you can change the default to a more commonly used angle like 90°. Close all files and then go to Layer > Layer Style > Global Light... to alter the default value.
Live Previewing

Test, test, test again, and then test some more! One of the best things you can do for your designs is look at it on the device(s) it’s going to end up on. There’s lots of software out there now which will live preview straight out of Photoshop, so no need to save out files and copy them across to the phone or any faffing like that. A couple worth checking out are Skala Preview for iOS (and now Android) and Android Design Preview for, you guessed it, Android.
Photoshop: Techniques
It’s a good idea with Shape Layers and text to change the colour using the object’s own setting instead of the Color Overlay Layer Style. The benefits of this are a) it’s quicker to update the colour later on as there’s no need to load up the Layer Style window, and b) it will make finding the object easier in the Layers palette. As an example: in which panel above is the blue square easier to find?
Object Gradients

The same applies to gradients – use a gradient fill layer instead of a Layer Style if possible.
Object Gradients

Dither

Whichever gradient method you use make sure the Dither option is selected. This will help smooth out the colour transition and prevent banding of the colours. With Photoshop CS5 you can only apply a dither to a gradient layer, but in CS6 you can use it on both.
Concise Layer Styles

Try not to spread Layer Styles across different layers, it’s much better if they’re all on one if possible – keeps things tidy and makes it easier to copy styles around between objects.
Scale Layer Effects

Although you can choose the Scale Styles option when you resize an entire document through Image Size... there are times when you want to scale individual objects and their Layer Effects. When you resize one of these objects the styling doesn’t automatically scale with it, but you can use the Scale Effects... option to change them as well – although you’ll need to know the percentage increase/decrease of the original shape to get the two to match. You can find this option by right-clicking the fx icon on the relevant layer.
At first glance it may seem that the only way to create a stroke with Layer Styles is the Stroke option, but in fact there are multiple ways to add them to a single shape. If you use the Inner/Outer Glows and Shadows, and set their Choke to 100%, you can also get solid outlines. The Stroke will always appear on top, followed by Inner Shadow and Inner Glow on the inside, and Outer Glow and Drop Shadow on the outside. Downsides? At thicker widths they can blur, and the Choke can cause rough-looking rounded edges.
Layer Style vs. Vector Strokes

If you want the absolute best quality strokes, and you’re using Photoshop CS6, then add a vector stroke directly to your Shape Layer rather than as a Layer Style. Not only are they better quality (more noticeable at thicker widths), but you have the option to use rounded, square, or bevelled edges, as well as dashed outlines. Another useful feature is that they can be scaled to half pixels, so if you’re designing for iOS you can set a non-Retina stroke to 0.5px which will then scale up to 1px when the size is doubled for Retina.
One feature that Photoshop could really do with is being able to edit a corner radius after you’ve drawn a Shape Layer. Fortunately there’s a script out there that solves this problem: Corner Editor. With it installed you can select a Shape Layer, bring up the window above from File > Scripts > Corner Editor, and change the radii value – you can even have different sizes for each corner. There’s also the option to use different styles, so you’re not just limited to rounded corners.
Complex Vectors

For complex vectors the best solution is to use Illustrator then copy and paste into Photoshop (using Shape Layers). Outline any strokes in the Illustrator original, otherwise they won’t import to Photoshop properly. Remember by reciting this phrase to yourself: “Don’t be a joke, outline the stroke”. If the vector is more than just a shape, for example a full colour Windows style icon, then it will have to be pasted as a Smart Object.
One quirk of pasting in a Shape Layer from Illustrator is that it sometimes shifts the object off-centre by 0.5px in either or both axes, resulting in blurred pixels (although with the new CS6 pixel snapping options this seems to be less of an issue now). Always have a quick look to see if this has happened, and if it has shift the shape back by half a pixel to its intended position.
Blending Modes

When creating effects remember to only use blending modes on items which will later be merged with other layers. In the example the Highlight layer will be exported as a separate asset, but when shown on its own the blending effect disappears and it becomes a solid white to black gradient.
The best solution is to recreate the effect using a layer that is independent of what is beneath it.
Text Alignment

When adding text make things easier for yourself in the future by matching the paragraph alignment to that in the design, so text that is supposed to look left aligned has this setting as well. If you then have to change the text it will still have the correct alignment.
If you’ve got a paragraph of text then use a text box instead of manually adding line breaks as they all have to be reset when text is changed or the typeface altered. With a text box though the text will wrap automatically, and the paragraph can easily be resized. Yay!
Fortunately Photoshop gives you the option to convert between freeform and boxed text, and vice versa, by selecting Type > Convert to Paragraph Text or Convert to Point Text, or right clicking on the layer and selecting the same options. For Photoshop CS5 these functions are found in the Layer > Type > menu.
Hyphenation

Most devices don’t support hyphenation so you might as well switch it off.
Leading

When adding paragraphs of text Photoshop will default to an automatic amount of leading, which is usually a bit too tight. Make your text easier to read by manually changing this amount – in the example the leading has been changed from (Auto) to 20pt.
There are a few different types of anti-aliasing in Photoshop which can be used to get the best legibility from text – play around with the settings to find the most suitable one.

For mockups of text on a device have a look through the various methods and see which one is closest to how it appears on-screen.
Lists

In some cases when creating lists, particularly those with graphics next to them, it’s better to put all the descriptions into one single text object and set the leading to match the item spacing, rather than using separate layers for each one. This makes it easier to align and space everything correctly.
The screens on mobile devices often have a higher pixel resolution (PPI) than that of a typical computer display, so you need to make sure you don’t create buttons and text that are too small to use.

Depending on the density of the screen you may have to zoom out to 50% or even 33% to see the size of things in real life, and if they're too small make 'em bigger!
Photoshop: Organisation
Is there anything more annoying than the “copy” that Photoshop adds on to every duplicated layer?! Remove that and some other visual clutter by going to the Layers Panel Options and switching off Use Default Masks on Fill Layers, Expand New Effects and Add “copy” to Copied Layers and Groups. Every little helps.
Don’t be selfish, give your layers proper names! It makes life a lot easier for the next person who has to work on your designs, and you’ll look amazing if the file gets sent off to a client. A good technique is to give each layer a name as they’re created, which is much easier than trying to do them all at once later on.
If you really want to make your files super special then order the layers nicely as well. A logical way is to follow how the objects appear in the design from left to right, top to bottom, just like reading a book (apologies if your first language goes in another direction!).

**Ordering Layers**

- **Naughty**
- **Nice**
Photoshop CS6 now has a search feature within the Layers panel, which coupled with good organisation can make layer navigation a breeze. Using consistent naming across the board will allow you to search for layers based on their name, or you can filter by kind – useful if you want to see all your text for example. There’s lots of other methods in there including Effect and [Layer] Colour, so have a play and see what systems you can come up with to filter and work on your layers.
Colour Coding

Here’s an example of how colour coding in the Layers panel can make it easier to navigate. Right click on the show/hide control to bring up the layer colour menu.

- Grey (“neutral”) used for reference items, for example wireframes or screenshots
- Red (“danger”) for old, unused elements
- Green here to show different states of the same button
- Core design doesn’t use colour labels
- Popup window
Expanded Layer Effects

Like a messy house guest, expanded Layer Effects can make it harder to find your way around. Keep them collapsed and things are a lot better.
Delete All Empty Layers

Try not to leave empty layers or layer groups scattered throughout your files as they add unnecessary clutter. There’s a handy script located in the File > Scripts menu called Delete All Empty Layers, which does exactly what it says on the tin!
Locked Layers

Locking layers is a great way to preserve an object when working on a file, but try to make sure that they’re unlocked when handing over to other designers. Digging through layer sets trying to find the rogue locked layer that’s preventing you from moving or deleting the group can get really frustrating!
Layer Comps: so close, yet so far. What could be a great way to show multiple variations or layouts in a file is held back by the fact that changing anything once they’re set screws them up, so you can’t really use them whilst working on a design. Best created once your document is XXXX_Final_Finished_Finito.psd.
Photoshop: Export
Using our ustwo™ Crop & Export scripts (see next page) we’ve tried to make the asset export process super easy. The first thing to do is set your files up properly for them to work: put every individual object that you want to export within its own layer group and give it an asset name; each group can contain as many layers as you want as the scripts work on everything at the root level. Also if you lay everything out separately as shown, rather than stacked on top of each other, you’ll end up with a useful asset reference sheet.
We’ve built some awesome Photoshop scripts that will run through a file and export all the individual assets as PNGs...no muss, no fuss. Just copy them from Scripts to your Adobe Photoshop CSx/Presets/Scripts folder, (re)start Photoshop and you’re good to go! There are a few variations:

**ustwo™ Crop & Export [filename]**

This will crop to each asset and then export the file as [filename][layername].png, so with a file called button.psd, and layer called _normal the exported asset would be called button_normal.png.

**ustwo™ Crop & Export [filename]**

Same script as above except in this case the filename is not added to the exported asset, only the layer name is used. For the example above the exported asset would be called _normal.png.

**ustwo™ Crop & Export +1px [filename]**

In this case the exported asset will have a 1px margin added around each edge so that it will work correctly in Flash. File naming works as with the normal Crop & Export.

**ustwo™ Crop & Export +1px [layername]**

Same as above, using the alternative naming method.

There are also a couple of additional scripts available which won’t crop the layers but will instead stick to the dimensions of the Photoshop file. This can be useful for things like screen comps where the actual content might change size, but you want all the exported PNGs to have the same dimensions.

**ustwo™ Export [filename][layername]**

**ustwo™ Export [layername]**
Check out the differences in file size of the two different PNGs here – Save As... has created a file that’s 26KB bigger than Save for Web. Well worth using the latter then!
Reducing File Size

Everyone’s happier when file sizes are kept down, so if you have an asset that doesn’t need transparency try converting it to an 8bit PNG. In the example above there’s no loss in quality from making the switch, but the file size has been almost halved.
If you want to shave a few more KB from your exported file sizes then give ImageOptim a whirl – simply drag and drop your files onto its window and watch as it works its magic. The app works on PNG, JPEG and GIF images by stripping out any unnecessary metadata such as comments and colour profiles, as well as optimising the compression used. As a side note if you’re developing for iOS then it might now be worth using ImageOptim as this article explains.
Reducing Photoshop File Sizes

A quick way to shave some of the size from your PSDs is to switch off the visibility of all the layers. Not always practical if a design requires a certain combination to be shown, but it can be useful if sending or uploading files and you want to keep things small. Zipping the file afterwards also dramatically reduces the size.
Some devices don’t support all the colours that you can see on your computer screen, which can cause visual degradation of your assets. To prevent this from happening convert them to 565 images using the XimagiC ColorDither SP plugin. 565 refers to the colour depth change from 24bit (8+8+8) to 16bit (5+6+5) (16.7 million to 65536 colours, a commonly supported amount on mobile screens); to counteract the reduction in colours the filter also applies dithering, which will prevent banding in any gradients.
The best way to apply 565 dithering to multiple files is to create a Photoshop Action and use the File > Automate > Batch tool. Export all the assets normally using one of the Crop & Export scripts, then set up an Action to apply the filter and export using Save for Web (rather than Save and Close in the Destination menu which will increase the file size). The action shown is included in Actions/PPP™.atn; you'll need to create a folder called export on your Desktop for the processed files to be saved in.
Photoshop: Tips
Strokes with a 1px thickness can look a little too thin on curved shapes (straight edges are fine though), so to strengthen the stroke without making it bigger also add a Glow using the settings shown. The difference is subtle, but it definitely helps.
Circular fades are really useful for loading icons and can be created easily with the Stroke Layer Style. The trick is to set Fill Type: Gradient and use Style: Angle.
Quick Shine

You can create a quick shine effect using a white inner shadow with a low Opacity value. Be careful though as the shape of the shine will follow that of the top edge of the layer it is applied to, so it tends to work best with rectangular or near-rectangular objects.
Add Noise with Inner Glow

You can quickly add a simple noise texture to an object using the *Inner Glow* Layer Style. Set the *Source* to *Center*, *Size* to 0, then vary the amount using the *Noise* setting.
Extracting Logos

Sometimes it can be difficult to obtain a decent vector logo, in which case a last resort is to extract one using this process. Another useful tip is to search a company’s site to see if they have any PDF documents available for download: they’ll often have logos in them which can then be opened in Illustrator.

1. **Flat logo merged to a white background**
   - Image > Adjustments > Invert
   - Then Select All and Copy

2. **Image > Adjustments > Desaturate**

3. **Image > Adjustments > Levels**
   - Use the black point picker to select the main grey colour

   Add a colour layer, add a layer mask, alt-click on the mask and then Paste. This will create a mask from the black and white logo image.

You now have a logo on a transparent background.
Star Fields

Have a play around with the settings in the Brushes panel to create some different brush effects, like a basic star field for example. By increasing the Size Jitter and Opacity Jitter the brushes become more random.
Patterns

Add a little something to your designs by including a pattern or texture. They’re easy to make using the Pattern tool: first draw a tile that can be repeated smoothly, drag a selection around it, then go to Edit > Define Pattern... to add it to the presets. This pattern can then be used throughout Photoshop, including the Layer Style panel. Experiment with Blend Modes and Opacity to alter the pattern’s look (black and white work well as they are neutral colours and will work with any underlying design).
Feeling a bit uninspired when it comes to colours and palettes? Then give Kuler a go! It’s an online service where users can create and browse through colour palettes, but there’s also an extension for it so you don’t even need to leave Photoshop.

Kuler

It’s an incredibly useful tool for creating colour schemes or finding a bit of inspiration.
Shortcuts
Paths

There are loads of shortcuts for the path tools to make working with them quicker. If you’ve got two existing Shape Layers you can combine the paths using Command + E. After drawing a path you can add another to it by pressing + or by holding down Shift; alternatively - or Alt will subtract from the shape. Once you’ve drawn the second path you can then quickly subtract and add it from the other by selecting it and pressing - or +.
If you’re editing a path with the Direct Selection Tool and you don’t want to accidentally select other Shape Layers in the document then tap Q to enter Quick Mask Mode, which will isolate the one you’re currently working on.

Command + Shift + H will hide the current path you’ve got selected - useful if you want to preview the shape without the path obscuring the edges.
When creating a selection hold down the Space key to move it around before letting go of the mouse button and fixing the size.

Use the square bracket keys [ and ] to adjust brush size up and down. Shift plus [ or ] will increase the brush hardness.
Select a layer and press the forward slash / key to lock transparency. On Shape Layers this will lock the position instead.

Collapse or expand all layer sets in a document by holding down the Command key and clicking on one of the triangle icons.
Hide all other layers by holding down Alt and clicking on the visibility icon.

To show or hide layers in a row click, hold down and drag the cursor across all the relevant visibility icons.
Shortcuts
Keyboard

**F** (Cycle screen modes)
Switch between normal, fullscreen with task bar and full screen with black background.

**Space bar** (Hand tool)
Temporarily selects the hand tool while held down, use to pan around an image.

**Command + ~** (Cycle open documents)
Acts like Alt + Tab in the OS, changing between open documents.

**Space + F** (Canvas background)
Cycles through canvas colours.

**X** (Switch colours)
Flips the foreground and background colours.

**D** (Default colours)
Resets foreground and background colours to black and white.

**Arrow keys** (Move selection outline)
Moves selection outline by 1px.

**Shift + Arrow keys** (Move selection outline)
Moves selection outline by 10px.

**Command + Arrow keys** (Move selection)
Moves selected layer or area by 1px.

**Command + Shift + Arrow keys** (Move selection)
Moves selected layer or area by 10px.

**Command + Option + A** (Select all layers)
Selects all layers in the layers palette.

**Command + Click layer thumbnail** (Load layer as selection)
Load layer transparency as a selection.

**Shift + Click mask** (Enable/disable layer mask)
Switch layer mask on and off.

**Alt + Click mask** (View mask)
Show the layer mask as a separate image which can be edited like a channel.
**Shortcuts**

**Keyboard**

**Command + Click mask** *(Load mask as selection)*
Loads up the mask as a selection.

**Command + Shift + I** *(Invert selection)*
Reverse the current selection so previously selected areas become deselected and vice versa.

**Command + D** *(Deselect)*
Removes current selection.

**Command + Shift + D** *(Reselect)*
Reloads the last selection.

**Command + J** *(Copy layer)*
Duplicate the currently selected layer.

**1 – 0** *(Change layer opacity)*
Adjust the selected layer opacity in 10% increments.

**Shift + [+/-]** *(Cycle blending modes)*
Cycle through layer blending modes.
Keyboard Shortcuts and Menus

Become a Photoshop lean machine by creating custom keyboard shortcuts using the Edit > Keyboard Shortcuts… dialog. In this example a couple have been created for Align Vertical and Horizontal Centres.

Another really useful thing to do is remove the Command + Q shortcut to prevent any accidental quits of Photoshop.
Introduction

Illustrator: deploy when Photoshop’s vector tools just aren’t quite up to the task! We tend to use it for creating complex vectors which can then be styled in Photoshop – that way they retain their scaleability but get all the visual treats that Layer Effects allow too.
It’s worth setting up the colour profiles in Illustrator as well – for example you might want to add some colour to vector sketches which match what you see in Photoshop.

As with its sibling, go to Edit > Colour Settings..., make sure Working Spaces > RGB is set to the screen specified in your System Preferences and Color Management Policies > RGB is Off.
Useful Settings

There are a couple of useful settings in Illustrator > Preferences. The first is to set the Units to Pixels for General and Stroke, which will mean all your dimensions will match up pixel for pixel with Photoshop.

Once this is done the keyboard increment can be set to 1px, which means the cursor keys can be used to nudge shapes and points around while remaining on whole pixel measurements.
Grids

Like Photoshop, the Illustrator grid can be set up in Illustrator > Preferences > Guides, Grid, & Slices..., again with useful 10px gridlines and 10 subdivisions.
Snap to Grid

Yup, you guessed it, stick Snap to Grid on too! Like Photoshop it’s located in the View menu.
Smart Guides

Sometimes you need to push the boundaries and break out of the grid, in which case a good alternative is to use Smart Guides for non-straight/off-grid shapes and points. In the example above a right-angled triangle has been placed below a circle; the Smart Guides have recognised where the two overlap and let you easily add a point where the two intersect.
The Transform window is your pixel precision best friend. It can either be used to check a whole shape (top row), or a single point (bottom row). Also, make use of the link option for the W and H boxes, so when one value is changed the other will also adjust by the same proportion, keeping the object in scale.
Align to Pixel Grid

The new super-villain of Illustrator! Make sure this option is deselected when drawing shapes – it will align objects on the artboard to the underlying grid, which can cause unexpected shifts in the position when strokes are added for example. To show the Options go to the Transform panel menu.
This is another one to be wary of: when **View > Pixel Preview** is on it can show pixels as being precise when in reality they’re not.
Preview Blurring

Nothing to worry about too much here, but sometimes Illustrator will show a shape as having blurred edges even though the dimensions are exact in the Transform window. This seems to be a bug with the program, but thankfully the blurring won’t appear when the shape is imported into Photoshop.
If you tried to name every layer in an Illustrator file you’d get nothing else done, but try to organise shapes into groups so you don’t end up with one massive artboard the size of a football pitch – not fun to scroll around!
Appendix
There’s a library of patterns available to use in Patterns/PPPattern™.pat and also ready applied as Layer Effects in Patterns/ PPattern™.psd
Thanks!

@pppustwo
@gyppsy